Issue description:
Password activation or reset link gets encoded differently for users with "+" character in their username (e.g., [email protected]). Thus, password reset page yields invalid email.
Cause:
- URL encoding issue
Workaround:
1. Copy the password activation or password reset link into an empty notepad.
2. Find the + character in the URL and replace is with %2B
3. Copy and paste changed URL into the browser's address bar
Original:
https://domainauth.domain.com/Account/InitPassword?resetCode=CfDJ8CaULC0B%2BJFAnYCRE9zUxmjguxkNTuv4c3lFKFF481%2BnN2Anmiaa9YDQWhUeFi0tx9zPIZDNrZpJlPTWvo3E0ctmQYMubNlMNlBAJr17JWGoBc%2FSY7kPrSG%2FCA3GhREBnau6LNTNAnjJBB%2Bh8O6ZwmEsM%2B4xy5B9SJUi5wxKFsxEkt%2F75KZFLXwlLgh8gzLVoo43cNN5czOATiMNQ3pYh8U%3D&confirmCode=CfDJ8CaULC0B%2BJFAnYCRE9zUxmienylYjPNEbWOzIfH225gQU7HffCZHXZl4UGiPh5eAZ9IdyHkUN5a%2FWlUNucoA1Cui0AGbmIde427B6zWlEg4k2jg4%2FprcPHbp2Df0q8uXMzORihLB4X6z9NaNxi3Y2zAfjrxWWir7PDnZ0SIlY%2BMkJDQh3r977AAmrwC3dTJhzEuImozsOui5oR81eOhiJtY%3D&email=user+[email protected]&subdomain=
Output:
https://domainauth.domain.com/Account/InitPassword?resetCode=CfDJ8CaULC0B%2BJFAnYCRE9zUxmjguxkNTuv4c3lFKFF481%2BnN2Anmiaa9YDQWhUeFi0tx9zPIZDNrZpJlPTWvo3E0ctmQYMubNlMNlBAJr17JWGoBc%2FSY7kPrSG%2FCA3GhREBnau6LNTNAnjJBB%2Bh8O6ZwmEsM%2B4xy5B9SJUi5wxKFsxEkt%2F75KZFLXwlLgh8gzLVoo43cNN5czOATiMNQ3pYh8U%3D&confirmCode=CfDJ8CaULC0B%2BJFAnYCRE9zUxmienylYjPNEbWOzIfH225gQU7HffCZHXZl4UGiPh5eAZ9IdyHkUN5a%2FWlUNucoA1Cui0AGbmIde427B6zWlEg4k2jg4%2FprcPHbp2Df0q8uXMzORihLB4X6z9NaNxi3Y2zAfjrxWWir7PDnZ0SIlY%2BMkJDQh3r977AAmrwC3dTJhzEuImozsOui5oR81eOhiJtY%3D&email=user%2B[email protected]&subdomain=